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Chú ý: Bài này chỉ là phiên bản sơ lược, thích hợp cho đa số người dùng 

mới tiếp xúc với WinVNKey. Nếu muốn tìm hiểu sâu hơn hoặc muốn khám 

phá các chức năng cao cấp hơn thì hãy đọc bài “ Tìm hiểu một số chức 

năng đặc biệt của phần mềm gõ WinVNKey ”. 

 
A. LỜI NÓI ĐẦU 
 

WinVNKey là phần mềm miễn phí để gõ chữ Việt và chữ các nước khác. Ngoài các chức năng 

giúp gõ chữ Việt được chính xác hơn và nhanh hơn, WinVNKey còn có rất nhiều chức năng mà 

các phần mềm khác chưa hỗ trợ hoặc có hỗ trợ nhưng chưa hoàn hảo.  

 

Bài này xin được giới thiệu vài chức năng hữu dụng đặc biệt của WinVNKey như sau:  

 

- Sửa các chữ biến dạng hoặc ô vuông trong email. 

- Hoán đổi chữ hoa/thường, chữ hoa đầu câu, đầu từ cho văn bản chữ Việt. 

- Tra dấu Hỏi Ngã. 

- Hỗ trợ bảng ký tự (Character Map) của Microsoft Windows và bàn gõ chữ Unicode. 

- Hoán chuyển bảng mã (bộ chữ) tiếng Việt cho văn bản trơn (plain text) và văn bản 

định dạng RTF (rich text format). 

 

Phần mềm WinVNKey có thể được tải xuống từ http://winvnkey.sf.net. WinVNKey có thể được 

cài đặt ở giao diện tiếng Anh hay tiếng Việt. Bài viết này dùng giao diện tiếng Việt hầu giúp cho 

đông đảo người Việt khắp nơi trên thế giới. Một số các chức năng của WinVNKey nằm ở các 

hyperlink màu xanh (Hình 1). Chẳng hạn muốn thay đổi dấu của các kiểu gõ, ta nhấn lên cụm 

chữ "Kiểu gõ" ở trang Chính. Ngoài ra WinVNKey còn cung cấp các chức năng khác thông qua 

menu ở nút "Chạy" (Hình 2). 

http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fchuvietnhanh.sourceforge.net%2FVaiChucNangDacBietCuaPhanMemGoWinvnkey.htm&width&layout=box_count&action=like&show_faces=true&share=true&height=65
https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fchuvietnhanh.sourceforge.net%2FVaiChucNangDacBietCuaPhanMemGoWinvnkey.htm&display=popup
https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fabout.twitter.com%2Fresources%2Fbuttons&text=Twitter%20Buttons%20%7C%20About&tw_p=tweetbutton&url=http%3A%2F%2Fchuvietnhanh.sourceforge.net/VaiChucNangDacBietCuaPhanMemGoWinvnkey.htm&via=chuvietnhanh
http://chuvietnhanh.sf.net/TimHieuMotSoChucNangDacBietCuaPhanMemGoWinvnkey.htm
http://chuvietnhanh.sf.net/TimHieuMotSoChucNangDacBietCuaPhanMemGoWinvnkey.htm
http://winvnkey.sf.net/
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Hình 1: Giao diện chính của WinVNKey.  
 

 
 

 Hình 2: Một số chức năng của WinVNKey nằm ở nút Chạy. 
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B. SỬA CÁC CHỮ BIẾN DẠNG HOẶC Ô VUÔNG TRONG EMAIL 
 

WinVNKey có thể chỉnh lại chữ trong email đã bị biến dạng nhiều lần do không chọn UTF-8 đúng 

cách hoặc phục hồi lại các chữ bị hiển thị thành ô vuông.    

 

Dưới đây là ví dụ thật đã xảy ra. Ta có thể dùng để thực tập: 

  

Tôi hỏi Vinh, bạn tôi, giúp tìm phần mềm hoán chuyển chữ Việt không dấu qua chữ có dấu. Khi 

mở email trả lời của Vinh, viết bằng chữ không dấu, phần email tôi đã gởi cho Vinh viết bằng 

chữ có dấu đã bị biến dạng. Nguyên văn email của Vinh như sau: 

 

Hello anh Binh 

Anh vao vovisoft trong do co muc chuyen tu nhung chu khong dau qua co dau nhung khong 

dung phan mem. 

Vay nhe anh binh. 

Vinh 

 

> tu binh tran <tubinhtran@gmail.com> wrote: 

 

> Hi Vinh, 

> HÃ´m trÆ°á»›c, nghe Vinh nÃ³i vÃ o site cá»§a vovisoft.com cÃ³ thá»ƒ 

> tháº¥y software hoÃ¡n chuyá»ƒn chá»¯ Viá»‡t khÃ´ng dáº¥u qua chá»¯ Viá»‡t cÃ³ dáº¥u. 

> TÃ´i cÃ³ vÃ o tÃ¬m nhÆ°ng khÃ´ng tháº¥y. 

> Váº­y Vinh xem láº¡i vÃ  cho tÃ´i cÃ¡i link dáº«n tá»›i software nÃ y nha. 

> Cáº£m Æ¡n Vinh. 

> Tráº§n TÆ° BÃ¬nh 

 

Để đọc đoạn email biến dạng trên, ta làm vài bước như sau: 

 

- Khởi động WinVNKey. ( Tải xuống từ http://winvnkey.sf.net ) 

- Chọn bôi đen [select] đoạn email biến dạng.  

- Nhấn thả phím Ctrl 2 lần, xong đè chuột phải 

- WinVNKey sẽ hiện thị bảng trình đơn (menu) như Hình 3. 

- Chọn “E6. Sửa các chữ biến dạng trong email”. 

- Tức thì sau vài giây, toàn bộ đoạn email bôi đen trên sẽ được phục hồi lại dạng tiếng 

Việt nguyên thủy và hiển thị trong một cửa sổ trình duyệt mới. 

- Nếu có một số chữ không hoán chuyển được, ta có thể lặp lại quá trình hoán chuyển 

vừa rồi nhưng chọn menu E5. 

 

http://winvnkey.sf.net/
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Hình 3: Bảng trình đơn của WinVNKey sau khi nhấn Ctrl 2 lần và đè chuột phải. 

 

Chú ý rằng menu E5 (hoặc E6) cũng có thể dùng để sửa lại email có những ký tự hình vuông 

như trong Hình 4. Sau khi hoán đổi, ta sẽ được Hình 5. 

 

 
 

Hình 4:  Yahoo Email bị lỗi ô vuông khi hiển thị một số mẫu tự Việt 

 

 
 

Hình 5:  Email sau khi sửa xong được hiển thị ở một cửa sổ trình duyệt mới. 
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C. HOÁN ĐỔI DẠNG CHỮ HOA/THƯỜNG 
 

WinVNKey có thể hoán đổi dạng chữ hoa/thường, chữ hoa đầu câu, chữ hoa đầu từ, cho văn 

bản được viết bằng bất cứ bảng mã nào trong số gần 100 bảng mã (bộ chữ) mà WinVNKey hỗ 

trợ: Unicode, VISCII, ABC, VNI, VPS, v.v. Muốn vậy, trước khi hoán đổi, ta phải chọn lựa đúng 

bảng mã ở trang Chính. 

 

Microsoft Word cũng có chức năng hoán đổi Unicode dạng chữ hoa/thường [Format > Change 

Case] nhưng chỉ áp dụng cho các chữ viết theo lối dấu rời (composed characters). Khi gặp chữ 

Việt Unicode dựng sẵn (precomposed characters), Microsoft giữ nguyên không hoán đổi ngoại 

trừ khi chữ đó trùng với những chữ dùng ở Tây Âu (như đ, à, á, ã, è, é, ù, ú, …). Chẳng hạn, 

khi chọn đổi sang chữ hoa, Microsoft Word sẽ đổi cụm chữ "Hoán đổi" thành ra "HOÁN ĐổI". 

Nếu gặp văn bản viết bằng các bảng mã Việt cũ (như ABC, VPS, …) Microsoft Word sẽ hoán đổi 

sai vì nó không hiểu những bảng mã này. 

 

Trong khi đó, WinVNKey cũng có đầy đủ chức năng hoán đổi Unicode dạng chữ hoa/thường y 

hệt như Microsoft Word (nghĩa là hỗ trợ tất cả các ngôn ngữ trên thế giới). Ngoài ra WinVNKey 

còn vượt trội hơn Microsoft Word ở những điểm sau đây: 

 

- Hỗ trợ cho tất cả chữ Việt Unicode dạng dựng sẵn. 

- Hỗ trợ cho tất cả văn bản viết bằng bảng mã Việt cũ như ABC, VPS, v.v. 

- Khả năng hoán đổi hoa/thường của WinVNKey có thể hoạt động với bất kỳ 

editor nào (như Word, Wordpad, Notepad, Email, browser, v.v.) chứ không 

phải bị giới hạn trong Microsoft Word mà thôi. 

 

Sau đây là cách hoán đổi bằng WinVNKey: 

 

- Khởi động WinVNKey. ( Tải xuống từ http://winvnkey.sf.net )  

- Chọn bảng mã (bộ chữ) ở trang Chính cho phù hợp với bảng mã của văn bản 

(thông thường là bảng mã Unicode). 

- Chọn bôi đen [select] đoạn văn đó.  

- Nhấn thả phím Ctrl 2 lần, xong đè chuột phải.  

- WinVNKey sẽ hiển thị bảng trình đơn (menu) như Hình 6. 

- Nhấn một tùy chọn thích hợp (từ A1 đến A5) để hoán chuyển sang chữ 

hoa/thường, chữ hoa đầu câu, chữ hoa đầu từ, v.v … 

 

http://winvnkey.sf.net/
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Hình 6: Bảng trình đơn của WinVNKey sau khi nhấn Ctrl 2 lần và đè chuột phải. 

 

Lưu ý:  Nếu văn bản là các trang Web thì ta phải Sao > Dán [Copy > Paste] vào 

Microsoft Word hoặc WordPad, v.v… rồi hoán đổi từ nơi này. Lý do là các trang Web 

không cho phép ta thay đổi chữ (read-only text), ngoại trừ khi các chữ đó nằm trong các 

hộp chữ cho phép người dùng gõ vào.  

 

 

D. TRA DẤU HỎI NGÃ 
 

Khi gõ chữ Việt mà phân vân không biết dùng dấu hỏi hoặc dấu ngã, ta có thể dùng chức năng 

tra dấu hỏi ngã của WinVNKey. 

 

Để tra dấu, ta làm vài bước như sau: 

 

- Khởi động WinVNKey. ( Tải xuống từ http://winvnkey.sf.net ) 

- Từ trang Chính, nhấn nút [Chạy > Tra hỏi ngã]. 

- WinVNKey sẽ hiển thị bảng “Tra Dấu Hỏi Ngã” như Hình 7. 

- Chỉ cần gõ một từ Việt với dấu hỏi hoặc ngã tùy ý vào ô chữ rồi nhấn nút "Tra chữ".  

WinVNKey sẽ hiển thị một danh sách các từ đơn hoặc phức dùng dấu hỏi hoặc ngã để 

cho ta chọn lựa. 

 

http://winvnkey.sf.net/
http://winvnkey.sf.net/
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Hình 7: Bảng Tra Dấu Hỏi Ngã.  

  

Lưu ý: Ta nên thay đổi phông (font) tương ứng với bảng mã (bộ chữ – charset) mà ta đã 

chọn ở Trang Chính, bằng cách nhấn nút “Đổi phông”. Vì cả hai hộp nhập và xuất đều 

dùng bộ chữ ta đã chọn trong "Trang Chính" của WinVNKey. Do đó, ta phải chọn phông 

thích hợp với bảng mã. Chẳng hạn: 

 

- "Arial" cho bộ chữ Unicode  

- "Sans Serif VISCII 1.1" cho bộ chữ VISCII  

- "Sans Serif ABC" cho bộ chữ TCVN-3 (tức ABC)  

- Phông với tiếp đầu ngữ "VPS" cho bộ chữ VPS  

- Phông với tiếp đầu ngữ "VNI" cho bộ chữ VNI … 

 

E. BẢNG KÝ TỰ (CHARACTER MAP) 
 

Để thuận tiện cho người dùng, WinVNKey cung cấp Bảng ký tự gồm có hàng vạn ký tự và ký 

hiệu rất phong phú để ta có thể lấy ra và chèn vào bài viết. Nó tương tự như bảng Symbol của 

Microsoft Word [Insert > Symbol] nhưng đầy đủ hơn nhiều. Có tất cả hai loại bảng ký tự: 

 

- Bảng ký tự của Microsoft Windows. 

- Bảng ký tự của WinVNKey (gọi là Bàn gõ chữ Unicode). 

 

Công dụng của hai bảng ký tự tương tự nhau nhưng Bàn gõ chữ Unicode hỗ trợ nhiều chức năng 

hơn, đặc biệt là các chức năng truy cập các chữ Hán Nôm. 

 

1. BẢNG KÝ TỰ CỦA MICROSOFT WINDOWS 

 

Đây là bảng Character Map của Windows mà ta có thể khởi động bằng một trong hai cách sau: 

 

- Từ trang Chính của WinVNKey:  Chạy > Chạy Charmap (xem Hình 2). 

- Hoặc từ menu: Start > All Programs > Accessories > System Tools > Character Map.  

 

WinVNKey sẽ hiển thị bảng Typing Tips (Hướng dẫn gõ) và bảng Character Map như Hình 8. 

Dựa theo khung Character Map, ta dễ dàng tìm và lấy ra các ký tự tùy thích. 
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Hình 8: Bảng ký tự của Microsoft hiển thị chữ tùy theo phông. 

 

2. BÀN GÕ CHỮ UNICODE CỦA WINVNKEY 

 

Từ trang Chính của WinVNKey, nhấn nút Chạy > Bàn gõ Unicode, ta sẽ được hộp thoại như Hình 

9.  Muốn chọn chữ nào, ta nhấn chuột lên chữ ấy và nó sẽ tự động xuất hiện trong ô "Chữ cần 

chép lại". Ta có thể nhấn lên nút "Chép lại" (copy) rồi dán (paste) chữ ấy vào các văn bản khác. 
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Hình 9: Bảng ký tự của WinVNKey hiển thị từng vùng mã 

 

Sự khác biệt lớn nhất giữa hai bảng ký tự Microsoft và WinVNKey là số lượng chữ: 

 

- Bảng ký tự của Microsoft chỉ hiển thị khoảng 60 ngàn chữ nằm trong mặt phẳng 

Unicode cơ bản (tức Mặt phẳng số 0). 

- Bàn Gõ Chữ Unicode của WinVNKey có thể hiển thị khoảng 300 ngàn chữ trong 

chuẩn Unicode (gồm Mặt phẳng số 0, 1, 2, 3, 14, 15). 

 

Bàn Gõ chữ Unicode của WinVNKey cho phép hiển thị từng hệ chữ (script/language) như liệt kê 

trong danh sách dropdown của combobox. Mỗi hệ chữ chiếm một vùng mã gồm có một hoặc 

nhiều trang, mỗi trang gồm 128 chữ. 

 

Hàng nút bên phải của Hình 10 cho phép ta truy cập các trang Unicode nhanh chóng. Mỗi lần 

nhấn nút dấu cộng hoặc dấu trừ, ta sẽ lật tới hoặc lật lui một hệ chữ. Mỗi lần nhấn mũi tên ốm, 

ta sẽ lật tới hoặc lật lui một trang. Mỗi lần nhấn mũi tên trung bình, ta sẽ lật tới hoặc lật lui 8 

trang. Mỗi lần nhấn mũi tên mập, ta sẽ lật tới hoặc lật lui 64 trang.  

 

Nếu biết mã số của chữ cần tìm, ta có thể dùng menu như Hình 9 bằng cách nhấn nút [Hệ chữ 

> Truy cập chữ]. WinVNKey sẽ hiển thị khung Nhập mã số (Hình 10), ta nhập mã số vào thì 

chữ cần tìm sẽ hiện ra trong Bàn Gõ Chữ Unicode. 
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Hình 10: Khung Nhập mã số nếu biết mã số của chữ cần tìm 

 

 

F. HOÁN CHUYỂN MÃ PHÔNG TIẾNG VIỆT 
 

1. TẠI SAO CẦN CHUYỂN MÃ TIẾNG VIỆT 

 

Hiện nay, đa số chúng ta và hầu như mọi trang mạng Việt ngữ đều dùng phông Unicode để gõ 

chữ Việt. Lý do vì Unicode là mã chuẩn quốc tế, nó hỗ trợ chữ Việt và được cài đặt ngay trong 

Windows. Từ hệ điều hành Windows 98 SE trở đi đều có hỗ trợ hệ thống phông Unicode. Khi 

soạn thảo bằng phông mã Unicode, người ta có thể đọc được chữ Việt tại bất kỳ nơi nào trên 

thế giới, miễn là máy tính đó có hỗ trợ Unicode. Các phông chuẩn của Unicode là: Times New 

Roman, Arial, Tahoma, Verdana, … 

 

Tuy nhiên các phông mã Unicode không hỗ trợ chữ Việt một cách đa dạng như chữ của các 

nước Âu Mỹ. Để việc in ấn chữ Việt được mỹ thuật hơn, các tờ báo, nhà xuất bản, … vẫn ưa 

dùng các loại phông của các bảng mã khác. Chẳng hạn như: 

 

- Các phông mã TCVN (ABC) có dạng .Vn (dấu chấm ở trước, sau đó đến chữ Vn). Vd: 

.VnTimes, .VnArial, ... 

- Các phông mã VISCII có chữ VI ở trước. Vd: VI Phong Lan, VI Thuy Tien, … 

- Các phông mã VNI có chữ VNI ở trước. Vd: VNI Times, VNI Helve, … 

- Các phông mã VPS có chữ VPS ở trước. Vd: VPS Times, VNI Long An, … 

 

Các văn bản chữ Việt soạn thảo bằng các bảng mã cũ như TCVN (ABC), VISCII, VNI, VPS, v.v. 

sẽ không thể hiển thị đúng được nếu ta không cài đặt các phông tương ứng của các mã trên vào 

máy tính. Bảng mã VNI được sử dụng rộng rãi ở miền Nam và bảng mã TCVN (ABC) được ưa 

chuộng ở miền Bắc.  Còn ở hải ngoại thì sử dụng nhiều loại bảng mã như VNI, VISCII, VPS. 

 

Chính vì có nhiều bảng mã Việt Nam khác nhau, mỗi nơi lại sử dụng các bảng mã khác nhau, 

dẫn đến tình trạng không đọc được các văn bản từ trong Nam gởi ra Bắc, hoặc từ trong nước 

gởi ra hải ngoại vì không có phông đúng. Từ đó có nhu cầu cần hoán chuyển văn bản sang bảng 

mã mà máy mình đang có thì mới đọc được. Đó cũng là một trong những mục tiêu của 

WinVNKey. 

 

WinVNKey có thể hoán chuyển bảng mã cho văn bản trơn (plain text) và văn bản định dạng 

RTF (rich text format). 

 

Văn bản trơn là văn bản chỉ gồm có những chữ mà ta gõ vào, chẳng hạn như văn bản do 

Notepad lưu trữ hoặc do Word, Wordpad lưu trữ ở dạng text.  Nếu mở văn bản này ra bằng 
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Notepad, ta chỉ thấy có nội dung (tức là chữ mà ta gõ vào văn bản) mà không thấy có dữ liệu 

về phông và định dạng. 

 

Văn bản định dạng RTF là văn bản vừa chứa nội dung lẫn dữ liệu về phông và định dạng (màu 

sắc, đậm lợt, cỡ chữ, loại chữ nghiêng, đậm, v.v.). Nếu mở văn bản này ra bằng Notepad, ta sẽ 

thấy có rất nhiều cụm chữ lạ không phải là những chữ mà ta đã gõ vào, thỉnh thoảng xen kẻ 

một số chữ nội dung. Những cụm chữ lạ này chính là những dữ liệu nói về phông và định dạng 

của các chữ trong văn bản. 

 

Chuyển mã văn bản trơn là thay đổi bảng mã của các chữ nội dung trong văn bản mà thôi. Còn 

chuyển mã văn bản định dạng RTF là một việc phức tạp hơn: thay đổi bảng mã của nội dung, 

thay đổi tên phông nhưng bảo toàn kiểu phông: màu sắc, đậm lợt, cỡ chữ, loại chữ nghiêng, 

đậm, v.v. 

 

2. CHUYỂN MÃ VĂN BẢN TRƠN 

 

Khi ta mở một tệp (file), chọn một đoạn văn nào đó rồi bôi đen và nhấn CTRL-C là ta đã copy 

đoạn văn đó vào trong bộ nhớ; vùng này gọi là clipboard hay bảng ghi tạm. Như vậy, văn bản 

có thể được chứa trong tệp, trên đĩa cứng hoặc chứa trong bộ nhớ clipboard. WinVNKey có khả 

năng đổi bảng mã của văn bản trơn khi nó nằm trong tệp hoặc trong clipboard. 

 

a. Chuyển mã từ tệp 

 

Để chuyển mã nguyên cả tệp văn bản trơn, ta phải lưu trữ văn bản ở dạng *.txt. Các word 

processors đều hỗ trợ lưu trữ ở nhiều dạng, trong đó dạng *.txt là dạng văn bản trơn: [Word 

Document (*.doc) > File > Save As > Plain Text (*.txt)]. Một số editor chỉ cho phép lưu trữ ở 

một dạng duy nhất là dạng văn bản trơn như Notepad.   

 

◊  Đã biết mã của văn bản nguồn  

 

Ví dụ: Ta có một tệp văn bản trơn, là câu ca dao về ơn nghĩa cha mẹ, mà ta đã biết là gõ bằng 

bảng mã (bộ chữ) VIQR. 

 

 
 

Hình 11:  Văn bản viết dưới dạng VIQR (còn gọi là VietNet)  

 

Tệp này ta đặt tên là ChaMe.txt và chứa trong thư mục (directory) C:\CaDao. 

 

Nay ta muốn chuyển mã tệp này qua mã Unicode và lưu giữ (save) nó dưới tên tệp tương tự 

trong một ngăn tiểu thư mục (subdirectory) khác. Ta làm các bước sau đây:  
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Hình 12:  Hoán chuyển văn bản trơn 

 

1. Khởi động WinVNKey. ( Tải xuống từ http://winvnkey.sf.net ) 

2. Từ Trang Chính, nhấn nút [Chạy > Hoán chuyển].  

3. WinVNKey sẽ hiển thị bảng Hoán Chuyển như Hình 12, ta điền thông số thích hợp 

vào ô “Tệp nguồn” và ô “Tệp đích” ở trang “Văn Bản Trơn”.  

4. Trong hàng “Văn bản nguồn”, chọn [Tệp] và [3.VIQR (Vietnet)] vì tệp nguồn ở mã 

VIQR.  

5. Trong hàng “Văn bản đích”, chọn [Tệp] và [4.Unicode] vì ta muốn chuyển tệp qua 

mã Unicode. 

6. Trong nhóm “Tệp nguồn”, nhấn nút có hình mở tệp  để đến thư mục và chọn 

đúng tệp nguồn.  

7. Trong nhóm “Tệp đích”, chọn tùy chọn [Cùng tên tệp, khác tên tiểu thư mục] theo 

cách như Hình 13: 

 

http://winvnkey.sf.net/
http://winvnkey.sf.net/
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Hình 13: Chọn cách tạo ra tệp đích 

 

(WinVNKey sẽ tự động điền vào ô “Thư mục” và ô “Tên tệp” ở nhóm “Tệp đích”. 

Nếu ta không thích các tên tệp và tên thư mục mà WinVNKey điền vào thì ta có thể 

sửa chúng lại theo ý riêng của ta). 

 

8. Nhấn nút “Hoán chuyển” để chuyển mã.  

9. Xem thông tin kết quả trong hộp “Kết quả”.  

10. Khi chữ hiện ra là “xong”, ta có thể xem lại kết quả chuyển mã ở tệp ChaMe.txt 

bằng cách nhấp mũi tên ở chữ màu xanh “Tên tệp”. Tệp ChaMe.txt sẽ hiện ra như 

Hình 14: 

 

 
 

Hình 14: Kết quả hoán chuyển văn bản dạng VIQR sang Unicode 

 

◊  Không biết mã của văn bản nguồn 

 

WinVNKey có thể tự đoán được mã của văn bản nguồn. Cũng cùng ví dụ tệp ChaMe.txt ở 

trên, nếu ta không biết chắc chắn mã của văn bản nguồn là mã gì, ở bước thứ 4, ta có thể 

chọn ["0. Tự động đoán bộ chữ ”] ở hàng “Văn bản nguồn” như Hình 15:  
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Hình 15:  Nhờ WinVNKey đoán bảng mã nguồn 

  

Sau đó, ta nhấn nút “Hoán chuyển”, hộp “Kết quả” sẽ cho thấy kết quả đoán bảng mã và 

kết quả chuyển mã.  

 

Nếu kết quả chuyển mã bị sai, ta có thể nhấn lên cụm chữ xanh "Kết quả" để xem chi tiết 

của việc đoán mã. Ta sẽ thấy danh sách các bảng mã được liệt kê dựa theo số lượng chữ 

sai chính tả từ ít lỗi nhất đến nhiều lỗi nhất. Bảng mã được chọn chính là bảng mã đầu 

tiên có ít chữ sai chính tả nhất. Trong trường hợp có nhiều bảng mã đồng hạng (có cùng 

số chữ sai chính tả), trên lý thuyết ta có thể chọn bất cứ bảng mã nào làm bảng mã nguồn 

cũng được.    

 

Nếu việc chọn bảng mã đầu tiên này cho ra kết quả hoán chuyển sai, ta hãy hoán chuyển 

lại. Lần này, ta chọn bảng mã nguồn là bảng mã thứ nhì (có ít lỗi thứ nhì) chứ không nên 

chọn "0. Tự động đoán bộ chữ”.  Cứ tiếp tục quá trình này chừng một vài lần, ta sẽ có kết 

quả chuyển mã đúng. 

 

b. Chuyển mã từ clipboard bằng hộp thoại Hoán Chuyển 

 

Nếu ta chỉ có nhu cầu chuyển mã một đoạn văn bản mà thôi, cách tốt nhất là copy đoạn văn 

bản đó vào clipboard rồi dùng chức năng chuyển mã từ Clipboard. Chức năng này chỉ thuần túy 

hoán chuyển mã của các chữ mà gạt bỏ tất cả các thông tin về định dạng, nghĩa là chỉ hoán 
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chuyển nội dung mà thôi. Do đó, ta có thể chuyển mã trên từng đoạn văn bản của tệp ở bất cứ 

dạng nào: *.doc, *.txt, Notepad, v.v… 

 

Ví dụ: Tôi mới mua máy vi tính. Trong máy có Microsoft Word và chỉ có các phông của mã 

Unicode (như Arial, Tahoma, Times New Roman …); chứ chưa tải xuống phông của các mã tiếng 

Việt nào khác, ngoài Unicode. Nay bạn tôi gởi cho tôi một bài ca dao tệp Hoa sen.doc gõ trên 

Microsoft Word và gởi qua email ở bản đính kèm (Attachment). Khi mở tệp ở Attachment ra, tôi 

thấy như Hình 17: 

  

 
  

Hình 16: Văn bản không đọc được vì dùng phông không đúng với bảng mã. 

 

Tôi không biết bài ca dao trên được bạn tôi gõ bằng bảng mã gì, nên để đọc được cũng như để 

lưu giữ bài ca dao ở mã Unicode, tôi làm các bước như sau: 
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Hình 17: Hoán chuyển văn bản nằm trong clipboard 

  

1. Trong Microsoft Word, chọn bôi đen văn bản rồi copy [Select All > Copy] thì toàn 

bộ văn bản sẽ được đưa vào bộ nhớ bảng ghi tạm (clipboard).  

2. Khởi động WinVNKey. ( Tải xuống từ http://winvnkey.sf.net )   

3. Từ Trang Chính, nhấn nút [Chạy > Hoán chuyển].  

4. WinVNKey sẽ hiển thị bảng Hoán Chuyển, ta chọn thông tin thích hợp cho hàng 

“Văn bản nguồn” và hàng “Văn bản đích” ở trang “Văn Bản Trơn” như Hình 17 ở 

trên.  

5. Nhấn nút “Hoán chuyển”.  

6. Xem kết quả chuyển mã trong hộp “Kết quả”.  

7. Trở lại Microsoft Word, chọn [Edit > Paste] để dán toàn bộ văn bản vừa được 

chuyển mã ở bảng ghi tạm trở lại MS Word. Kết quả như Hình 18:  

  

http://winvnkey.sf.net/
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Hình 18: Văn bản sau khi copy trở lại từ clipboard 

  

Lưu ý: Trong bước 1, ta có thể chọn bôi đen chỉ một phần của tệp. Ta cũng có thể dùng 

[Cut] thay vì [Copy]. 

 

c. Chuyển mã từ clipboard bằng bảng trình đơn (menu) 

 

Phương pháp chuyển mã từ clipboard vừa trình bày ở trên tương đối mất thời giờ vì phải thông 

qua hộp thoại Hoán Chuyển Văn Bản Trơn. WinVNKey hỗ trợ một phương pháp hoán chuyển rất 

nhanh như sau: 

 

 
 

Hình 19: Bảng trình đơn của WinVNKey sau khi nhấn Ctrl 2 lần và đè chuột phải. 

 

1. Khởi động WinVNKey. 

2. Chọn bôi đen [select] một đoạn văn bản. 

3. Nhấn thả phím Ctrl hai lần. 
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4. Đè chuột phải để hiện ra menu hoán chuyển như Hình 19. 

5. Rồi nhấn chuột lên menu hoán chuyển B (Hình 19). 

6. Kết quả hoán chuyển sẽ lập tức thay thế đoạn chữ bôi đen mà ta không cần phải 

dán (paste) gì cả.  

 

Đôi khi ta chỉ muốn đổi để xem thử kết quả mà thôi chứ không muốn kết quả hoán chuyển thay 

thế đoạn chữ bôi đen. WinVNKey đã tiên liệu trường hợp này và cung cấp menu E1.  Cụ thể 

trong 5 bước kể trên, bước (4) và (5) được thay thế như sau: 

  

(4)  Rồi nhấn chuột lên menu hoán chuyển E1 (xem Hình 19)  

(5)  Kết quả hoán chuyển sẽ được chứa trong một tệp nháp và hiển thị bằng Notepad. 

 

d. Chuyển mã từ clipboard bằng phím nóng 

 

Nếu để ý nhìn menu hoán chuyển ở Hình 20, ta sẽ thấy như sau: 

 

- Menu B có shortcut <CTRL-C> <CTRL> <B>, nghĩa là nhấn CTRL-C để copy, rồi 

nhấn thả phím Ctrl một lần, xong nhấn phím B (đừng nhấn phím Shift).  

- Menu E1 có shortcut <CTRL-C> <CTRL> <D>, nghĩa là nhấn CTRL-C để copy, 

nhấn thả phím Ctrl một lần, xong nhấn phím D (đừng nhấn phím Shift). 

 

Tóm lại, thay vì dùng chuột, ta có thể dùng phím nóng như sau:  

 

i. Để hoán chuyển và thay thế trực tiếp trong văn bản: 

  

 Chọn bôi đen một đoạn văn bản  

 Nhấn chuỗi phím <CTRL-C> <CTRL> <B>  

 

ii. Để hoán chuyển và hiển thị trong tệp nháp: 

  

 Chọn bôi đen một đoạn văn bản  

 Nhấn chuỗi phím <CTRL-C> <CTRL> <D>  

 

 

3. HOÁN CHUYỂN PHÔNG CHO VĂN BẢN ĐỊNH DẠNG RTF (Rich Text Format) 

 

WinVNKey có khả năng hoán chuyển văn bản RTF từ nhiều phông nguồn sang nhiều phông đích 

khác nhau. Khi WinVNKey hoán chuyển phông, nó cũng tự động đổi luôn bảng mã (bộ chữ) của 

phông nguồn sang bảng mã của phông đích mà không cần người dùng làm công việc chuyển 

mã. 

   

Chức năng hoán chuyển văn bản RTF của WinVNKey có đặc điểm là bảo toàn kiểu phông, màu 

sắc, đậm lợt, cỡ chữ, loại chữ nghiêng, v.v. của văn bản nguồn. 

  

Để hoán chuyển văn bản RTF, ta phải lưu trữ (save) văn bản ở dạng *.rtf. Cách lưu trữ: [Word 

Document (*.doc) > File > Save As > Rich Text Format (*.rtf)]. 

 

Ví dụ: Một nhà xuất bản có một tệp văn bản “Tuyển Tập Truyện Ngắn” (Tuyen Tap Truyen 

Ngan.doc) viết bằng MS Word Document với nhiều phông của Unicode hoặc VPS, hoặc TCVN 

khác nhau, kích cỡ khác nhau, màu sắc khác nhau. Nay muốn đổi sang phông VNI để in thành 

sách vì từ lâu đã hệ thống in ấn đã quen dùng phông chữ VNI, nhà xuất bản này có 3 chọn lựa 

như sau: 

  

(a) Mở tệp nguyên thủy ra, copy từng đoạn một, hoán chuyển mã, rồi dán (paste) 

trở lại. Phương pháp này đã được mô tả ở mục F.2.c và F.2.d.i  ở trên. 

  

(b) Hoặc lưu trữ (save) văn bản ở dạng *.txt rồi đổi từ văn bản trơn qua mã VNI, 

xong tự mình khôi phục lại định dạng.  
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Khi lưu trữ văn bản ở dạng *.txt, tất cả thông tin về định dạng sẽ mất đi, chỉ còn 

nội dung văn bản mà thôi. Muốn phục hồi lại định dạng, ta phải tự làm lại từ đầu 

một cách thủ công: dùng Microsoft Word để mở văn bản, tự điều chỉnh lại định 

dạng, màu sắc, kiểu chữ sao cho giống với văn bản gốc, rồi cuối cùng lưu trữ văn 

bản ở dạng *.doc và in ra giấy.  

 

(c) Hoặc lưu trữ văn bản ở dạng *.rtf rồi nhờ WinVNKey đổi sang phông VNI.  

  

Sau khi đổi xong, văn bản mới sẽ hầu như giống hệt văn bản nguồn. Ví dụ nếu văn 

bản nguồn dùng phông Times New Roman hoặc VPS-Times thì văn bản đích sẽ tự 

động được đổi qua phông VNI-Times vì phông này gần giống phông Times New 

Roman hoặc VPS-Times. Có tinh mắt mới nhìn ra sự khác biệt giữa các phông VNI-

Times, VPS-Times và Times New Roman.  

 

Nếu nhà xuất bản chọn cách (c) thì phải làm các bước như sau: 

  

 
  

Hình 20: Hộp thoại hoán chuyển văn bản định dạng RTF.  

 

1. Dùng Microsoft Word để mở tệp “Tuyển Tập Truyện Ngắn”. Giả sử tệp này là 

“Tuyen Tap Truyen Ngan.doc” nằm trong thư mục (directory) “C:\Download”.  
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2. Lưu trữ tệp này ở dạng *.rtf [Word Document (*.doc) > File > Save As > Rich Text 

Format (*.rtf)].  

3. Từ Trang Chính WinVNKey, chọn [Chạy > Hoán chuyển]. WinVNKey sẽ hiển thị 

bảng Hoán Chuyển như Hình 20.  

4. Điền thông số thích hợp vào nhóm “Tệp nguồn” và nhóm “Tệp đích” ở trang “Văn 

Bản RTF” như hình này.   

5. Trong nhóm “Chọn bảng đổi phông - Bảng”, chọn [Đổi sang phông VNI] vì ta muốn 

chuyển tệp qua phông VNI.  

6. Trong nhóm “Tệp nguồn”, nhấn nút có hình mở tệp  để đến thư mục và chọn 

đúng tệp nguồn.  

7. Trong nhóm “Tệp đích”, chọn tùy chọn [Cùng tên tệp, khác tên tiểu thư mục] theo 

Hình 21 như sau:  

 

 
 

Hình 21:  Chọn thư mục cho tệp đích 

 

(WinVNKey sẽ tự động điền vào ô “Thư mục” và ô “Tên tệp” ở nhóm “Tệp đích”. Nếu ta 

không thích các tên tệp và tên thư mục mà WinVNKey điền vào thì ta có thể sửa chúng 

lại theo ý riêng của ta).  

 

8. Nhấn nút “Hoán chuyển” để chuyển phông.  

9. Xem thông tin kết quả trong hộp “Kết quả”.  

10. Khi chữ hiện ra là “xong”, ta có thể xem lại kết quả chuyển phông ở tệp “Tuyen 

Tap Truyen Ngan.rtf” bằng cách nhấp mũi tên ở chữ màu xanh “Tên tệp”.  

11. Sau cùng, lưu giữ tệp này ở dạng nguyên thủy *.doc [Rich Text Format (*.rtf) > 

File > Save As > Word Document (*.doc)].  

  

  

Từ ví dụ trên, ta có thể chuyển từ phông này sang phông khác một cách dễ dàng, chẳng hạn ta 

có bài viết trong máy dùng phông chữ VISCII, TCVN, VPS, VNI, … ta có thể đổi sang phông của 

Unicode rồi đưa lên mạng một cách rất nhanh chóng. 

  

Nói chung, chức năng hoán chuyển văn bản RTF của WinVNKey rất phong phú.  Trên đây chỉ 

một ví dụ căn bản mà thôi. Muốn biết chi tiết, ta xem thêm phần “Hướng dẫn” ở trong khung 

“Đổi Phông RTF” [Trang Chính WinVNKey > Chạy > Hoán chuyển > Văn bản RTF > Bảng > Mũi 

tên màu đen kế chữ Bảng]. 

  

Cần nói thêm, có sự khác biệt giữa các phần mềm khác và WinVNKey về hoán chuyển văn bản 

RTF. 

  

◊ Các phần mềm khác: Coi toàn bộ văn bản được viết theo 1 bảng mã duy nhất, thí dụ là VNI.  

Rồi tiến hành đổi mã, xong đổi tên fonts. Vì lý do này, nếu tệp nguồn có chứa nhiều bảng mã 

(có đoạn dùng VNI, có đoạn dùng VPS, có đoạn dùng ABC, có đoạn dùng Unicode, v.v.) thì các 

phần mềm này không đổi được. 

  

◊ WinVNKey: Ta không cần chọn bảng mã nguồn và bảng mã đích. Ta có thể dùng nhiều loại 

phông/bảng mã khác nhau trong tệp nguồn (có nghĩa là có thể có một số cụm chữ là VNI, một 

số cụm chữ khác là VPS, v.v.). 

 

Ta có thể quyết định tên phông đích. Thí dụ, khi đổi ra phông Unicode, ta có thể chọn như sau: 

  

http://winvnkey.sf.net/
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- Tất cả phông nguồn tựa tựa như Courier (VISCII phông Minh Quan, VNI phông 

Aptima, VPS phông x nào đó, v.v.) ta có thể chọn đổi ra Courier New.  

- Tất cả phông nguồn tựa tựa như Times (VISCII phông VI Times, VNI phông VNI-

Times, VPS phông x nào đó giống Times, …) ta có thể chọn đổi ra Times New Roman. 

tương ứng trên máy tính đó. Các font Unicode chuẩn là: Times New Roman, Arial, Tahoma, Ve 

G. KẾT LUẬN 
 

Ngoài các chức năng đặc biệt được trình bày ở trên, WinVNKey còn nhiều chức năng đa dạng 

khác. Muốn tìm hiểu các chức năng này, khi chạy WinVNKKey, chỉ cần nhấn các chữ màu xanh 

(hyperlinks) liên hệ để được giải thích tỉ mỉ.  

 

WinVNKey là phần mềm gõ chữ Việt và các ngôn ngữ khác trong môi trường Windows do nhóm 

thảo chương TriChlor tại Hoa-Kỳ thực hiện từ năm 1992. Kể từ phiên bản 4.x.x trở đi, TS Ngô 

Đình Học đã nâng cấp WinVNKey lên thành bộ gõ đa ngữ. WinVNKey chạy trên Windows 

NT/2K/XP/2003/Vista. 

 

Riêng những ai chưa thạo dùng máy vi tính, có thể đọc thêm bài “Hướng dẫn cấp tốc phần mềm 

gõ WinVNKey” ở http://chuvietnhanh.sf.net . Bài này hướng dẫn cách hạ tải, cài đặt WinVNKey 

vào máy, cách chọn các chức năng thường dùng trong WinVNKey. 

 

**************************************************************************** 

 

PHỤ LỤC 
 

Vài điều căn bản về 
 

QUẢN LÝ PHÔNG TIẾNG VIỆT CHO WINDOWS 
 

(Phần Phụ Lục được viết phỏng theo Lê Hoàn – Mediazone)  

 

 

1. Bao nhiêu phông thì đủ dùng?  

2. Cách cài thêm phông chữ.  

3. Cách bỏ bớt phông chữ.  

  

 

1. Bao nhiêu phông thì đủ dùng? 

  

Việc cài đặt phông cho Windows nhiều hay ít tùy vào nhu cầu của người dùng, nhưng số lượng 

quá lớn cũng sẽ làm ảnh hưởng đến tốc độ làm việc của Windows. Đối với đa số người dùng, số 

lượng phông cơ bản được Windows cung cấp sẵn là đủ dùng, không cần phải cài đặt thêm. 

  

Tuy nhiên, một số phần mềm gõ tiếng Việt hay đồ họa khi cài đặt sẽ tự động bổ sung thêm rất 

nhiều phông vào Windows, và việc cài đặt các bộ phông tiếng Việt với đủ loại bảng mã (ABC, 

VISCII, VNI, VPS, BK, …) cũng làm tăng đáng kể tổng số phông. Để giảm bớt số lượng phông 

của Windows, bạn có thể thực hiện theo các nguyên tắc sau: 

 

- Để đọc văn bản tiếng Việt: Ta chỉ cần cài một phông đại diện cho một bảng mã tiếng 

Việt là bạn đủ khả năng đọc được tất cả văn bản tiếng Việt, thí dụ: chỉ cần cài một 

phông cho bảng mã VNI 1 byte, một phông cho bảng mã VNI 2 byte là có thể đọc 

được tất cả văn bản được soạn thảo bằng phông VNI mà không cần cài cả bộ phông 

VNI với hàng trăm kiểu phông khác nhau. 

 

- Để in văn bản tiếng Việt: Bạn nên cài một bộ phông chuẩn có nhiều kiểu phông để 

phục vụ in ấn. Khi cần in văn bản được soạn với các bộ phông tiếng Việt khác, bạn 

nên hoán chuyển qua phông/mã của bộ phông chuẩn rồi tùy chọn kiểu phông phù 

hợp với kiểu phông nguồn trước khi in là xong. 

 

http://chuvietnhanh.sf.net/HuongDanCapTocPhanMemGoWinvnkey.htm
http://chuvietnhanh.sf.net/HuongDanCapTocPhanMemGoWinvnkey.htm
http://chuvietnhanh.sf.net/
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- Đối với phông tiếng Anh: Nếu ta không có nhu cầu chế bản chữ in thì không cần cài 

thêm bất cứ phông nào của các ứng dụng ngoài các phông chữ của Windows.  

 

2. Cách cài thêm phông chữ. 

 

Ta nhấn chuột: Start > chọn Control Panel > nhấn 2 lần lên biểu tượng Fonts. 

Trong cửa sổ Fonts, ta nhấn vào: File > Install New Font ...  

Tìm đường dẫn đến thư mục chứa phông cần cài đặt rồi chọn phông muốn cài đặt bằng cách 

nhấp chuột vào phông đó (giữ phím Ctrl nếu muốn chọn nhiều phông khác nhau) sau đó nhấn 

vào nút OK là phông sẽ được cài đặt.  

  

 3. Cách bỏ bớt phông chữ. 

  

Ta nhấn chuột: Start > Control Panel > nhấn 2 lần lên biểu tượng Fonts. 

Trong cửa sổ Fonts, ta bấm nút cuối cùng bên phải của thanh công cụ để chọn kiểu liệt kê chi 

tiết (Details). Ta có thể nhấn 2 lần vào tên Fonts để xem kiểu chữ của nó như thế nào, và nếu 

có những phông ta không cần đến, có thể chọn xóa nó đi nhưng chú ý những điểm sau: 

 

- Không được xóa các phông có biểu tượng chữ A màu đỏ và chữ O màu xanh. 

- Chỉ nên xóa những phông có biểu tượng chữ TT và không trùng ngày với các phông 

cơ bản khi cài Windows. 

 

 

© Trần Tư Bình & TS Ngô Đình Học (Web: Chữ Việt Nhanh, WinVNKey). 

Email: tubinhtran@gmail.com 

 

Chú ý: Bài này chỉ là phiên bản sơ lược, thích hợp cho đa số người dùng mới tiếp xúc với 

WinVNKey. Nếu muốn tìm hiểu sâu hơn hoặc muốn khám phá các chức năng cao cấp hơn thì 

hãy đọc bài “ Tìm hiểu một số chức năng đặc biệt của phần mềm gõ WinVNKey ” ở trang Chữ 

Việt Nhanh http://chuvietnhanh.sf.net (phần Bài Đọc Thêm). 

http://chuvietnhanh.sf.net/
http://winvnkey.sf.net/
http://chuvietnhanh.sf.net/TimHieuMotSoChucNangDacBietCuaPhanMemGoWinvnkey.htm
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